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Virtual Dashboards 

The EFILive virtual dashboards can be customized to suit any data-logging situation, 
from fuel mixture analysis, to chasing down intermittent faults, to analyzing spark 
advance and everything in between. 

A single dashboard layout cannot provide all the information that you need for each 
different scanning situation. EFILive allows you to customize and save multiple 
dashboard layouts. At first, customizing your dashboard may appear complex and 
overwhelming. Sometimes changing one thing can cause unexpected results 
elsewhere. However, once you begin to understand the powerful and flexible 
relationship between dashboard items, dashpages, dashboards and PID selections, you 
will discover that customizing a dashboard, or even setting up a completely new 
dashboard is really quite simple. 

Terminology 

Firstly we need to understand the terminology used to describe various parts of 
EFILive’s virtual dashboard system. 

A dash-item is a gauge, a status or a chart: 

 Gauge: Displays a single PID’s current value. Gauges can be one of three 
basic shapes: Analog, Bar or Digital. 

 Status: Displays the current status values for a single PID. 

 Chart: Displays the logged data for up to 4 PIDs. 

 
Analog gauge 

 
Bar gauge 

 
Digital gauge 

 
Status 

 
Chart 

 
Example dashboard items 

A dashpage is one of the three dash pages named A, B or C, displayed in the Scan 
Tool on the [Dashboard (F10)] tab page. Dashpages usually contain multiple dash-
items. 

A dashboard is the set of the three dash pages: A, B and C. 

A theme is a collection of dash-items. The collection may be based on “look and feel” of 
the dash-items it contains, or it may be based on their function or whatever other criteria 
the theme designer wants. A theme is just a directory that contains dash-items 
belonging to it. A Theme’s primary purpose is to organise dash-items into easy to find 
groups. 

The PID selection file is the name of the *.pid file that is currently loaded into the Scan 
Tool. 
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Relationships 

The next thing that really needs to be understood, is the hierarchical relationship that 
exists between the different components used to construct and customize dashboards. 

The most important part of configuring a dashboard is selecting the group of PIDs that 
you want to see. The group of PIDs that you select should be saved in a PID selection 
file. The PID selection file name determines the dashboard file name that will be loaded 
and displayed in the Scan Tool. 

Whenever EFILive opens a PID selection file, it searches the VDash folder for a 
matching virtual dashboard file. If it finds a matching virtual dashboard file, then that 
dashboard is loaded and displayed. If no matching file is found, then the default 
dashboard is loaded and displayed. 

 
Whether the metric or imperial version of the default dashboard is 
loaded depends on the regional settings of the PC. If the regional 
setting is US, then the Default imperial dashboard is loaded, otherwise 
the default metric dashboard is loaded. 

Once the dashboard has been loaded, EFILive then loads each of the three dash 
pages. 

More than one dashboard may share the same dash page. If you have a common dash 
page that contains your favourite dash items, then you may include that dash page in 
multiple dashboards. Any changes to the dash page will be reflected in all dashboards 
that display the dash page. 

More than one dash page may share the same dash items. If you have common dash 
items, such as RPM or Throttle Position, then you may include those dash items on 
multiple dash pages (even in multiple dashboards). Any changes to the dash item will 
be reflected in all dash pages that display the dash item. 
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Heirarchy 

The following diagram illustrates just one of many ways that a set of three dashboards 
may be configured. Based on three PID selection files, each matching dashboard 
contains three dash pages. 

Each dashpage (A, B or C) displays one or more dash-items, usually from the 
dashboard’s own theme. If required, some dash items may be “imported” from other 
themes. 

Theme: BLUE 

DYNO.pid 

Theme: GREEN 

Theme: RED 

FUEL.vdb 

A 
B 

C 

DYNO.vdb 

A 
B 

C 

SPARK.vdb 

A 

B 
C 

SPARK.pid FUEL.pid 
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The Default Dashboard 

We recommend that you never change the default dashboards, dash pages or dash 
items. The defaults settings will usually be overwritten each time you install an EFILive 
software update. 

If you want to modify the default dashboards supplied with the EFILive software, then 
follow these steps: 

1. Load in the default dash that you wish to modify. 

2. Select menu option File->Save as->Save dashboard as… and specify a new 
name for your modified dashboard. That will create four new files <name>.vdb, 
<name>_A.vdp, <name>_B.vdp and <name>_C.vdp where <name> is the 
dashboard name that you chose. 
A new theme folder named after the dashboard will be created and copies of all 
dash-items will be saved into the theme folder. 

 

 
If you do change the default dashboards and later want to restore them 
back to their original settings, use the menu option Dashboard->Recall 
installation defaults. 

 

Creating an exclusive copy of a dashboard item 

Sometimes you may not want to create an entirely new dashboard, instead you may 
want to just make a copy of an existing dash-item. 

Right click on the dashboard item and select properties. 

Click on the [Save as…] button and enter a new “Theme” name. We recommend using 
a theme name that is the same as (or is related to) the dashboard name. Then click 
[Save]. 
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Creating a new dashboard 

This tutorial is step-by-step guide to creating your first dashboard from scratch. We are 
going to create a dashboard to show the following data: 

 Engine Speed (RPM) 

 Throttle Position (TP) 

 Engine Coolant Temperature (ECT) 

 Intake Air Temperature (IAT) 

 Spark Advance (SPARK) 

 Knock Retard (KR) 

 
Any modifications to the default dashboards, the default dash pages or the 
default dash-items may be overwritten next time EFILive is updated. 
We recommend creating new dashboards, new dash pages and new dash-items 
for customization. 

The steps we will follow are: 

1. Select the PIDs. 

2. Create a new dashboard. 

3. Create dash-gauges. 

4. Create dash-charts. 

5. Customize the dashboard layout. 

 

 
If you ever resize the Scan Tool Window you can easily adjust the size 
of all the dashboard items and maps (on the Map tab page) to fit the 
new window size. 

Just click on the  icon (Hotkey Ctrl+F) in the main toolbar. 
 
If you resize the Scan Tool window using the pre-set sizes under the 
Window menu then the dashboard items and maps are automatically 
resized. 
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Step 1: Select the PIDs 

Open the [PIDs (F8)] tab page. 

Clear all selected PIDs by clicking on the Clear existing PID selection mini-toolbar 
icon in the top left corner of the PID display. 

 

Select the PIDs that you want to place on the dashboard: 

 Engine RPM {SAE.RPM} 

 Absolute Throttle Position {SAE.TP} 

 Engine Coolant Temperature {SAE.ECT} 

 Intake Air Temperature {SAE.IAT} 

 Ignition Timing Advance for #1 Cylinder {SAE.SPARKADV} 

 Retard Due to Knock {GM.KR} 

 
You can select a PID by double clicking on it, or by pressing the Insert 
key. You can unselect a PID by double clicking on it or by pressing the 
Delete key. 

Click on the Save PID selection with a new name mini-toolbar icon and save the PID 
selection with the name Blacky. 

 

 

 
Save the PID selection using the same name that we will use for our 
dashboard. In this tutorial the dashboard will be called “Blacky”, so 
save the PID selection as Blacky. 
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Step 2: Create a new dashboard 

Open the [Dashboard (F10)] tab page. 

Click on the Clear dashboard (all pages) dashboard toolbar icon. 

 

Click on the Save dashboard with a new name (all pages) dashboard toolbar icon. 

 

Enter the dasboard name Blacky, then click on [Save]. 

 
You can check the file names of the dashboard and dashpages by 
moving the mouse into the dashpage area. The dashboard and the 
active dashpage filenames are displayed in the status bar at the 
bottom of the window. 
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Step 3: Create dash gauges 

Select dashpage A. 

Right-click anywhere in the dashpage and select Add->Gauge->New gauge. 

A new, blank gauge will appear. 

 

Right click on the gauge and select Properties. 

In the [General] tab page, select “Engine RPM (RPM)” from the Parameter drop down 

list. 

Click [Ok]. 

The Save gauge window will appear, enter the theme name “Blacky” and click [Save]. 

 

 

Repeat step 3 to create gauges for: 

 Absolute Throttle Position {SAE.TP} 

 Engine Coolant Temperature {SAE.ECT} 

 Intake Air Temperature {SAE.IAT} 

 Ignition Timing Advance for #1 Cylinder {SAE.SPARKADV} 

 Retard Due to Knock {GM.KR} 

 
New dash items are always positioned in the same place on the dashpage. If 
you have not moved or resized the previous dashboard item, then the new item 
will most likely obscure the previous item. It can sometime look as if the previous 
item has reverted to a blank item. 
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Step 4: Create dash charts. 

Select dashpage B. 

 
You can place charts on any dashpage, however they are easier to 
manage if you keep them all on one page. EFILive can distribute all 
charts evenly across a single dash page – if the dashpage contains 
charts only. 

Right-click anywhere in the dashpage and select Add->Gauge->New gauge. 

A new, blank chart will appear. 

 

Right click on one of the Unused series captions. 

Select Other PIDs->{SAE.RPM} (RPM), you will be asked to save the chart if it has not 
already been saved. 

 

Select the “Blacky” theme, enter a name for the chart and then click on [Save]. 

Right click on each of the other Unused series captions and select a PID for each of 
them. You may mix and match PIDs from Metric PIDs, Imperial PIDs and Other PIDs 
in the same chart if you want.  

Add more charts If you want to see more than four PIDs. 

Click on the Distribute charts evenly in window main toolbar icon (Hotkey Ctrl+W) to 
stretch all charts to their maximum width and maximum height. 
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Step 5: Customize the dashboard layout. 

Each item displayed on the virtual dashboard can be repositioned and resized. 
Normally the dashboard is locked, which prevents accidental moving or resizing of 
dashboard items. Before you can start repositioning or resizing the dashboard items, 
you must unlock the dashboard. 

Right click anywhere on the dashboard, select Dash settings, and uncheck Lock 
dashboard. Every time you start the Scan Tool, or load a new dashboard, this 
setting defaults back to locked. When the dashboard is unlocked, the mouse pointer 
will change shape depending on where it is positioned on a dashboard item. Imagine 
that each dashboard item has invisible borders and an invisible title bar. 

The gauge below has been altered to show these invisible sections, called handles. 
The handles are positioned the same way on the status and chart dashboard items 
as well. 

 

The following table shows what the mouse pointer 
will look like when it is positioned over each of the 
different handles. 

Cursor Position within dashboard item 

 Title bar handle. 

 Top or bottom edge handle. 

 Left or right edge handle. 

 
Top-left or bottom-right corner 
handle. 

 
Top-right or bottom-left corner 
handle. 

To resize the item, position the mouse so that it is 
over the handle you wish to affect (the mouse 
pointer will change shape). Then click and hold the 
left mouse button while moving the mouse. Release 
the mouse button when the handle is at the desired 
position and/or size. 

  

 
Changing the size of an item in its property editor will not change the size of 
the original item. 

 


